import re
regex = re.compile(r"\"cid:[a-f0-9-]*\">[^<]+<\/a>")
test_str = "<a href=\"cid:c524ae03-7ac7-4823-9a28-af17a6acf12f\">"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")