#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "A\w*e\s"
Local $sString = "Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]" & @CRLF & _
"(IUPAC: Disilver sulfide)" & @CRLF & _
"Acetamide (1974-039) 10.AA.20 [21] [22] [23]" & @CRLF & _
"(IUPAC: Acetic acid amide)" & @CRLF & _
"Achalaite (2013-103) 04.?? [24] [no] [no]" & @CRLF & _
"Achavalite (Y: 1939"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")