import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "A\\w*e\\s";
final String string = "Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]\n"
+ "(IUPAC: Disilver sulfide)\n"
+ "Acetamide (1974-039) 10.AA.20 [21] [22] [23]\n"
+ "(IUPAC: Acetic acid amide)\n"
+ "Achalaite (2013-103) 04.?? [24] [no] [no]\n"
+ "Achavalite (Y: 1939";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}