# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"A\w*e\s"
test_str = ("Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]\n"
"(IUPAC: Disilver sulfide)\n"
"Acetamide (1974-039) 10.AA.20 [21] [22] [23]\n"
"(IUPAC: Acetic acid amide)\n"
"Achalaite (2013-103) 04.?? [24] [no] [no]\n"
"Achavalite (Y: 1939")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.