$re = '/A\w*e\s/';
$str = 'Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]
(IUPAC: Disilver sulfide)
Acetamide (1974-039) 10.AA.20 [21] [22] [23]
(IUPAC: Acetic acid amide)
Achalaite (2013-103) 04.?? [24] [no] [no]
Achavalite (Y: 1939';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);