#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:(?!g1|g2).)*(?:g21|g22)(?:(?!g31|g32|g41|g42).)*(?:g11|g12)).*?(?:g11|g12).*$"
Local $sString = "'g11'" & @CRLF & _
"'g31 g11'" & @CRLF & _
"'g41g11'" & @CRLF & _
"'g11 g21 g11'" & @CRLF & _
"'anything or nothing g11 anything or nothing'" & @CRLF & _
"'anything or nothing g31 anything or nothing g11'" & @CRLF & _
"'anything'" & @CRLF & _
"''" & @CRLF & _
"" & @CRLF & _
"'g31 g21 g11'" & @CRLF & _
"'g21 g11 g31'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")