use strict;
my $str = '\'g11\'
\'g31 g11\'
\'g41g11\'
\'g11 g21 g11\'
\'anything or nothing g11 anything or nothing\'
\'anything or nothing g31 anything or nothing g11\'
\'anything\'
\'\'
\'g31 g21 g11\'
\'g21 g11 g31\'
';
my $regex = qr/^(?!(?:(?!g1|g2).)*(?:g21|g22)(?:(?!g31|g32|g41|g42).)*(?:g11|g12)).*?(?:g11|g12).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}