const regex = new RegExp('^(?!(?:(?!g1|g2).)*(?:g21|g22)(?:(?!g31|g32|g41|g42).)*(?:g11|g12)).*?(?:g11|g12).*$', 'gm')
const str = `'g11'
'g31 g11'
'g41g11'
'g11 g21 g11'
'anything or nothing g11 anything or nothing'
'anything or nothing g31 anything or nothing g11'
'anything'
''
'g31 g21 g11'
'g21 g11 g31'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}