# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^", -]*)\s*-\s*([^," ]*)/$2 $1/gm;t' <<< "\"Bjerre- Jonas, Jorgensen- Silas, Wohlert- Johan, Madsen- Bo\""