$re = '/([^", -]*)\s*-\s*([^," ]*)/m';
$str = '"Bjerre- Jonas, Jorgensen- Silas, Wohlert- Johan, Madsen- Bo"';
$subst = "$2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;