import Foundation
let pattern = #"([^", -]*)\s*-\s*([^," ]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""Bjerre- Jonas, Jorgensen- Silas, Wohlert- Johan, Madsen- Bo""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)