package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^", -]*)\s*-\s*([^," ]*)`)
var str = `"Bjerre- Jonas, Jorgensen- Silas, Wohlert- Johan, Madsen- Bo"`
var substitution = "$2 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}