#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\d\/ :]+:[^:]+:(.*)$|(.*)$"
Local $sString = "11/04/2015 11:45:01: James: Cheers guys, enjoy the weekend!" & @CRLF & _
"" & @CRLF & _
"11/04/2015 12:08:55: Sarah: Sounds good James" & @CRLF & _
"" & @CRLF & _
"11/04/2015 12:09:24: Sarah: What are the details of the trip?" & @CRLF & _
"" & @CRLF & _
"11/04/2015 12:19:06: Leah: Driving up on Friday." & @CRLF & _
"Saturday we'll hit the beach." & @CRLF & _
"Sunday paaaaarty!" & @CRLF & _
"" & @CRLF & _
"11/04/2015 12:29:54: James: Nice."
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)