import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d\\/ :]+:[^:]+:(.*)$|(.*)$";
final String string = "11/04/2015 11:45:01: James: Cheers guys, enjoy the weekend!\n\n"
+ "11/04/2015 12:08:55: Sarah: Sounds good James\n\n"
+ "11/04/2015 12:09:24: Sarah: What are the details of the trip?\n\n"
+ "11/04/2015 12:19:06: Leah: Driving up on Friday.\n"
+ "Saturday we'll hit the beach.\n"
+ "Sunday paaaaarty!\n\n"
+ "11/04/2015 12:29:54: James: Nice.";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}