re = /^[\d\/ :]+:[^:]+:(.*)$|(.*)$/m
str = '11/04/2015 11:45:01: James: Cheers guys, enjoy the weekend!
11/04/2015 12:08:55: Sarah: Sounds good James
11/04/2015 12:09:24: Sarah: What are the details of the trip?
11/04/2015 12:19:06: Leah: Driving up on Friday.
Saturday we\'ll hit the beach.
Sunday paaaaarty!
11/04/2015 12:29:54: James: Nice.'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result