import re
regex = re.compile(r"^[\d\/ :]+:[^:]+:(.*)$|(.*)$", flags=re.MULTILINE)
test_str = ("11/04/2015 11:45:01: James: Cheers guys, enjoy the weekend!\n\n"
"11/04/2015 12:08:55: Sarah: Sounds good James\n\n"
"11/04/2015 12:09:24: Sarah: What are the details of the trip?\n\n"
"11/04/2015 12:19:06: Leah: Driving up on Friday.\n"
"Saturday we'll hit the beach.\n"
"Sunday paaaaarty!\n\n"
"11/04/2015 12:29:54: James: Nice.")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)