using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<br[^<>]*>(?i)";
string input = @"<div>some text<br id=""first""/>some more text<br id=""second""/></div>
<div>some text<br id=""first""/>some more text<br id=""second""/><br /></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}