$re = '/<br[^<>]*>(?i)/';
$str = '<div>some text<br id="first"/>some more text<br id="second"/></div>
<div>some text<br id="first"/>some more text<br id="second"/><br /></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);