re = /<br[^<>]*>(?i)/
str = '<div>some text<br id="first"/>some more text<br id="second"/></div>
<div>some text<br id="first"/>some more text<br id="second"/><br /></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end