package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<br[^<>]*>(?i)`)
var str = `<div>some text<br id="first"/>some more text<br id="second"/></div>
<div>some text<br id="first"/>some more text<br id="second"/><br /></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}