// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<br[^<>]*>(?i)").unwrap();
let string = "<div>some text<br id=\"first\"/>some more text<br id=\"second\"/></div>
<div>some text<br id=\"first\"/>some more text<br id=\"second\"/><br /></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}