package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\b00|\+)39[\. ]??)??3\d{2}[\. ]??\d{6,7}\b`)
var str = `hello this is my number +39 3331111111 how are you?`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}