import re
regex = re.compile(r"((\b00|\+)39[\. ]??)??3\d{2}[\. ]??\d{6,7}\b")
test_str = "hello this is my number +39 3331111111 how are you?"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")