import Foundation
let pattern = #"((\b00|\+)39[\. ]??)??3\d{2}[\. ]??\d{6,7}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hello this is my number +39 3331111111 how are you?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}