re = /((\b00|\+)39[\. ]??)??3\d{2}[\. ]??\d{6,7}\b/
str = 'hello this is my number +39 3331111111 how are you?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end