using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?";
string input = @"hi 127.0.0.1
a20.20.20.21
s210.s2121.212.
3210.232.
200.200.500.23
200.200.200
www.google.com:2020
look at http://www.google.com:8080, please
google.com
http://www.google.com
https://google.com
https://www.google.com
https://www.google.com:12345
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}