import re
regex = re.compile(r"(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?", flags=re.MULTILINE)
test_str = ("hi 127.0.0.1\n"
"a20.20.20.21\n"
"s210.s2121.212.\n"
"3210.232.\n"
"200.200.500.23\n"
"200.200.200\n"
"www.google.com:2020\n"
"look at http://www.google.com:8080, please\n"
"google.com\n"
"http://www.google.com\n"
"https://google.com\n"
"https://www.google.com\n"
"https://www.google.com:12345\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")