$re = '/(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?/m';
$str = 'hi 127.0.0.1
a20.20.20.21
s210.s2121.212.
3210.232.
200.200.500.23
200.200.200
www.google.com:2020
look at http://www.google.com:8080, please
google.com
http://www.google.com
https://google.com
https://www.google.com
https://www.google.com:12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);