use strict;
my $str = 'hi 127.0.0.1
a20.20.20.21
s210.s2121.212.
3210.232.
200.200.500.23
200.200.200
www.google.com:2020
look at http://www.google.com:8080, please
google.com
http://www.google.com
https://google.com
https://www.google.com
https://www.google.com:12345
';
my $regex = qr/(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}