// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:http(?:s?)://)?(?:[\w]+\.)+[a-zA-Z]+(?::\d{1,5})?").unwrap();
let string = "hi 127.0.0.1
a20.20.20.21
s210.s2121.212.
3210.232.
200.200.500.23
200.200.200
www.google.com:2020
look at http://www.google.com:8080, please
google.com
http://www.google.com
https://google.com
https://www.google.com
https://www.google.com:12345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}