const regex = /(?<=[a-zA-Z])\.(?=[a-zA-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z])\\.(?=[a-zA-Z])', 'g')
const str = `s the title says, I want to split a string using java regex based on dot but only if the dot appears in between alphabets.
Lets say the string is: System.out.println(5.55);
I need output as System out println(5.55);
anasd fhte rea.awefwelfkajs dflakwejf `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}