use strict;
my $str = 's the title says, I want to split a string using java regex based on dot but only if the dot appears in between alphabets.
Lets say the string is: System.out.println(5.55);
I need output as System out println(5.55);
anasd fhte rea.awefwelfkajs dflakwejf ';
my $regex = qr/(?<=[a-zA-Z])\.(?=[a-zA-Z])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}