$re = '/(?<=[a-zA-Z])\.(?=[a-zA-Z])/';
$str = 's the title says, I want to split a string using java regex based on dot but only if the dot appears in between alphabets.
Lets say the string is: System.out.println(5.55);
I need output as System out println(5.55);
anasd fhte rea.awefwelfkajs dflakwejf ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);