import Foundation
let pattern = #"(?<=[a-zA-Z])\.(?=[a-zA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
s the title says, I want to split a string using java regex based on dot but only if the dot appears in between alphabets.
Lets say the string is: System.out.println(5.55);
I need output as System out println(5.55);
anasd fhte rea.awefwelfkajs dflakwejf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)