# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[a-zA-Z])\.(?=[a-zA-Z])"
test_str = ("s the title says, I want to split a string using java regex based on dot but only if the dot appears in between alphabets.\n\n"
"Lets say the string is: System.out.println(5.55);\n\n"
"I need output as System out println(5.55);\n"
"anasd fhte rea.awefwelfkajs dflakwejf ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.