using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"map_masked.*masked$";
string input = @"subdirectory/something_map_masked_something_masked
subdirectory/something_map_masked_something_masked.hdr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}