// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)map_masked.*masked$").unwrap();
let string = "subdirectory/something_map_masked_something_masked
subdirectory/something_map_masked_something_masked.hdr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}