$re = '/map_masked.*masked$/m';
$str = 'subdirectory/something_map_masked_something_masked
subdirectory/something_map_masked_something_masked.hdr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);