re = /map_masked.*masked$/m
str = 'subdirectory/something_map_masked_something_masked
subdirectory/something_map_masked_something_masked.hdr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end