const regex = /map_masked.*masked$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('map_masked.*masked$', 'gm')
const str = `subdirectory/something_map_masked_something_masked
subdirectory/something_map_masked_something_masked.hdr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}