import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\\\begin\\{[^\\{\\}]*\\}(?:(?!\\\\(?:end|begin)).|(?R))*\\\\end\\{[^\\{\\}]*\\}";
final String string = "meh meh\n\n"
+ "\\begin{itemize}\n"
+ "\\item something1\n"
+ "\\begin{itemize}\n"
+ "\\item something1.1\n"
+ "\\item something1.2\n"
+ "\\end{itemize}\n"
+ "\\item something2\n"
+ "\\begin{itemize}\n"
+ "\\item something2.1\n\n"
+ "\\item something2.2\n"
+ "\\end{itemize}\n"
+ "\\end{itemize}\n\n"
+ "blah blah\n\n"
+ "\\begin{itemize}\n"
+ "\\item somethingelse1\n"
+ "\\item somethingelse2\n"
+ "\\end{itemize}\n\n"
+ "the end.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}