$re = '/(?s)\\\\begin\{[^{}]*}(?:(?!\\\\(?:end|begin)).|(?R))*\\\\end\{[^{}]*}/m';
$str = 'meh meh
\\begin{itemize}
\\item something1
\\begin{itemize}
\\item something1.1
\\item something1.2
\\end{itemize}
\\item something2
\\begin{itemize}
\\item something2.1
\\item something2.2
\\end{itemize}
\\end{itemize}
blah blah
\\begin{itemize}
\\item somethingelse1
\\item somethingelse2
\\end{itemize}
the end.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);