const regex = /(?s)\\begin\{[^{}]*}(?:(?!\\(?:end|begin)).|(?R))*\\end\{[^{}]*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\\\begin\\{[^{}]*}(?:(?!\\\\(?:end|begin)).|(?R))*\\\\end\\{[^{}]*}', 'gm')
const str = `meh meh
\\begin{itemize}
\\item something1
\\begin{itemize}
\\item something1.1
\\item something1.2
\\end{itemize}
\\item something2
\\begin{itemize}
\\item something2.1
\\item something2.2
\\end{itemize}
\\end{itemize}
blah blah
\\begin{itemize}
\\item somethingelse1
\\item somethingelse2
\\end{itemize}
the end.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}