use strict;
my $str = 'meh meh
\\begin{itemize}
\\item something1
\\begin{itemize}
\\item something1.1
\\item something1.2
\\end{itemize}
\\item something2
\\begin{itemize}
\\item something2.1
\\item something2.2
\\end{itemize}
\\end{itemize}
blah blah
\\begin{itemize}
\\item somethingelse1
\\item somethingelse2
\\end{itemize}
the end.';
my $regex = qr/(?s)\\begin\{[^{}]*}(?:(?!\\(?:end|begin)).|(?R))*\\end\{[^{}]*}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}