# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D*\d+(*SKIP)(*F)|\d+//g;t' <<< "foo123bar123baz123456abc1111def123456789"