#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\D*\d+(*SKIP)(*F)|\d+"
Local $sString = "foo123bar123baz123456abc1111def123456789"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)