$re = '/^\D*\d+(*SKIP)(*F)|\d+/';
$str = 'foo123bar123baz123456abc1111def123456789';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;