#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "value='[A-Za-z]+\,[0-9]+\,([A-Za-z0-9]+)\,([A-Za-z0-9]+)'>[A-Za-z0-9]+\s-\s(.*)?\s\("
Local $sString = "<option value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>" & @CRLF & _
"<option value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>" & @CRLF & _
"<option value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>" & @CRLF & _
"<option value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>" & @CRLF & _
"<option value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>" & @CRLF & _
"<option value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>" & @CRLF & _
"<option value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>" & @CRLF & _
"<option value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>" & @CRLF & _
"<option value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>" & @CRLF & _
"<option value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>" & @CRLF & _
"<option value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>" & @CRLF & _
"<option value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")