import re
regex = re.compile(r"value='[A-Za-z]+\,[0-9]+\,([A-Za-z0-9]+)\,([A-Za-z0-9]+)'>[A-Za-z0-9]+\s-\s(.*)?\s\(")
test_str = ("<option value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>\n"
"<option value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>\n"
"<option value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>\n"
"<option value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>\n"
"<option value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>\n"
"<option value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>\n"
"<option value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>\n"
"<option value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>\n"
"<option value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>\n"
"<option value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>\n"
"<option value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>\n"
"<option value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")