// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"value='[A-Za-z]+\,[0-9]+\,([A-Za-z0-9]+)\,([A-Za-z0-9]+)'>[A-Za-z0-9]+\s-\s(.*)?\s\(").unwrap();
let string = "<option value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>
<option value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>
<option value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>
<option value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>
<option value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>
<option value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>
<option value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>
<option value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>
<option value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>
<option value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>
<option value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>
<option value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}